Our team has been closely monitoring the platform over the past few days and has not observed any issues. We are now marking this incident as resolved.
Posted Oct 27, 2025 - 17:05 UTC
Update
The cloud platform situation has stabilized, and all services are operating normally. No errors or alerts have been detected within standard operations in Xponent. Our team continues to monitor the environment closely.
If you notice any unexpected behaviour, please contact CSG’s Global Service Desk via the MyCSG Support Portal (https://www.csgi.com/mycsgcustomer-support/) or call the phone number listed at the bottom of the page for your region.
Posted Oct 20, 2025 - 23:16 UTC
Update
Most Hub services remain operational. We are currently experiencing intermittent issues affecting certain external and internal connections. These disruptions are linked to a networking degradation within our cloud provider environment, impacting DNS resolution and routing.
Our team is actively working to mitigate the impact and maintain service stability. We will continue to monitor the situation closely and share updates as more information becomes available.
Posted Oct 20, 2025 - 19:28 UTC
Update
All services continue to be fully operational. We are continuing to monitor system performance and stability, and no further issues have been observed.
We will keep the status at “Monitoring” for now and plan to mark this incident as “Resolved” if everything remains stable.
If you notice any unexpected behaviour, please contact CSG’s Global Service Desk via the MyCSG Support Portal (https://www.csgi.com/mycsgcustomer-support/) or call the phone number listed at the bottom of the page for your region.
Posted Oct 20, 2025 - 16:10 UTC
Monitoring
We have checked all services and can confirm that everything is fully operational. We are now moving the status page to "Monitoring" status and will continue to observe system performance for the next few hours before marking this incident as "Resolved".
If you notice any unexpected behaviour, please contact CSG’s Global Service Desk via the MyCSG Support Portal (https://www.csgi.com/mycsgcustomer-support/) or call the phone number listed at the bottom of the page for your region.
Posted Oct 20, 2025 - 12:03 UTC
Investigating
Our applications in US East (N. Virginia) region are currently experiencing service degradation due to an ongoing issue with our underlying cloud provider.
We are actively investigating the impact and will continue to provide updates as we make further progress. Thank you for your patience.