Degraded Performance in JS Microservice US Region Stacks

Incident Report for Xponent

Resolved

After monitoring the platform over the past several days, we can confirm that the issue has been resolved and performance remains stable. This incident is now considered resolved.
Posted Oct 13, 2025 - 15:06 UTC

Monitoring

A fix has been implemented under release 25.2.1 to address the intermittent errors in the JS microservice that were causing degraded performance for a small subset of executions. Based on this update, we are actively monitoring the platform to ensure stability and confirm improvement.

We kindly ask users to also keep an eye out for any unusual behavior or recurring issues and report them through the usual channels, as this feedback will help us validate the effectiveness of the fix.

Thank you for your collaboration and continued patience as we ensure optimal performance across all projects.
Posted Oct 09, 2025 - 17:44 UTC

Identified

The issue has been identified and action plan is under construction.
Posted Oct 01, 2025 - 15:51 UTC

Investigating

We are investigating intermittent errors in the JS microservice that may result in degraded performance for a small percentage of executions. So far, reports have been limited to the US region, and the impact is confined to certain projects, particularly those with large queries or dependencies on external services.

Our engineering team is implementing platform-level improvements to strengthen resilience and reduce timeouts. For projects where execution times are contributing to timeouts, we are coordinating directly with your customer representative to review and optimise those workloads.

We are actively investigating the situation and will provide updates as progress is made. Thank you for your understanding and patience.
Posted Sep 27, 2025 - 16:06 UTC

Identified

We are investigating intermittent errors in the JS microservice that may result in degraded performance for a small percentage of executions. So far, reports have been limited to the US region, and the impact is confined to certain projects, particularly those with large queries or dependencies on external services.

Our engineering team is implementing platform-level improvements to strengthen resilience and reduce timeouts. For projects where execution times are contributing to timeouts, we are coordinating directly with your customer representative to review and optimise those workloads.

We are actively investigating the situation and will provide updates as progress is made. Thank you for your understanding and patience.
Posted Sep 27, 2025 - 16:06 UTC