Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 14, 2025 - 04:00 UTC
Scheduled
Planned Date: Start: 11-14-2025 04:00 UTC End: 11-14-2025 08:00 UTC
Summary: We will be deploying updates to Bill Explainer Microsite & Studio as part of the 26.1.2 rollout. This update introduces fixes for Custom Widgets and Dynamic Item explanation & new client implementations.
Next Steps: As we make progress during the maintenance window, we will provide updates. Once the upgrade is complete, all affected components will be marked as complete.
If you notice any unexpected behavior, please contact CSG’s Global Service Desk team via the MyCSG Support portal here: https://www.csgi.com/mycsgcustomer-support/ or call the phone number listed at the bottom of the page for your region.
Posted Nov 12, 2025 - 16:59 UTC
This scheduled maintenance affected: PREMIUM EXPERIENCE APPLICATIONS (Bill Explainer Microsite API - US East (N. Virginia), Bill Explainer Studio - US East (N. Virginia)).