Incident Status: Resolved Impact: Minor Description: The issue affecting Xponent Email in the US East region has been fully resolved. Our monitoring has not detected any further errors, and all services are operating normally.
Incident Start Time: February 24, 2026, 18:53 UTC Incident End Time: February 24, 2026, 19:40 UTC
Next Steps: • No action is required. • If you notice unexpected behavior, please contact CSG’s Global Service Desk via the MyCSG Support Portal (https://www.csgi.com/mycsgcustomer-support/) or call the phone number listed at the bottom of the page for your region.
Posted Feb 24, 2026 - 22:20 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 24, 2026 - 20:22 UTC
Monitoring
Incident Status: Monitoring Impact: Minor Description: At 18:53 UTC we received an alert from our third-party vendor of ongoing issues with their transmission API. The issue affecting Xponent Email in the US East region has been mitigated. All impacted components are currently stable, and services are operating normally. We are continuing to monitor system performance to ensure stability. This issue may have caused delayed email delivery.
Next Steps: • We will continue to monitor performance and provide updates if any new issues are detected. • If you notice unexpected behavior, please contact CSG’s Global Service Desk via the MyCSG Support Portal (https://www.csgi.com/mycsgcustomer-support/) or call the phone number listed at the bottom of the page for your region.
Posted Feb 24, 2026 - 20:21 UTC
This incident affected: COMMUNICATIONS (CX Channels - Email - AWS US East (N. Virginia)).